This website uses cookies for visitor traffic analysis. By using the website, you agree with storing the cookies on your computer.More information

Question about unexpected behaviour in Design Mode

Frequently asked questions about VisionX.

Question about unexpected behaviour in Design Mode

Postby ANH » Mon Oct 08, 2018 3:10 pm

Hello,

we've encountered a problem with the design mode of the VisionX wizard.
There we had the problem that controls were not associated correctly to their columns though the column names were set correctly, but was suplied by a function calls. We tested a bit and came to this case:

Code: Select all
    UIEditor editDocId = new UIEditor();       
    // ...
    editDocId.setDataRow(rdb);       
    // ...
    String colName = "this_is_not_a_column_name";
    editId.setColumnName(colName);
    colName="id_column_name";


The Control 'editId' shows nothing while the applications runs in normal mode, because "this_is_not_a_column_name" is not a valid column name of the databook 'rdb'.

In design mode the control 'editId' was bound to the column of the databook named "id_column_name".

About this I have two questions:

1) What are save ways to suply the name of a column as an argument for setColumnName?

2) Is it correct, that in design mode our code is actually not exectuted as usual?
2a) ...and therefore no logging works at all?

Thank you!

Best Regards
Andreas
ANH
 
Posts: 11
Joined: Fri Jun 29, 2018 11:42 am

Re: Question about unexpected behaviour in Design Mode

Postby Support@SIB » Tue Oct 09, 2018 3:47 pm

This question is related to the commercial product VisionX.
Please contact the product support!
User avatar
Support@SIB
 
Posts: 257
Joined: Mon Sep 28, 2009 1:56 pm


Return to VisionX